Page 1 of 1

bash_custom

PostPosted: Jan 17th, '10, 19:25
by wschil20
A you might be aware, when you log on, and every time you open a terminal, Linux checks to see if you have a file called /stuhome/bash_custom or /fachome/bash_custom

If you have a bash_custom, it will be run at your permissions level (duh :ugeek: )

Here are some useful suggestions for customizing your environment.
(Credits to Dave Hale, Malcolm Kesson, Joe Pasquale, and Ken Huff for helping)


1. Make sure you have a bash_custom and you're allowed to execute it, just in case.
Code: Select all
touch /stuhome/bash_custom
chmod 777 /stuhome/bash_custom


2. Next, the first line of your bash_custom should read
Code: Select all
#!/bin/bash
Now you can customize

3(maya). By default, Maya saves your preferences to your computer locally, which get deleted when you log off. To save your prefs to your network (stuhome AKA H:\ in windows, like "My Documents") use this:
Code: Select all
if [ -d /stuhome/maya ]
   then
     rm -rf /home/$USER/maya
     ln -s /stuhome/maya /home/$USER/maya
fi


4(houdini). You can do the same for Houdini prefs:
Code: Select all
if [ -d /stuhome/houdni10.0 ]
    then
     rm -rf /home/$USER/houdini10.0
     ln -s /stuhome/houdni10.0 /home/$USER/houdini10.0
fi

***edit, there's a better way to do this, but I forgot off the top of my head.***

5(gnome). To customize your gnome environment, use gconftool-2. I like to have hidden files visible by default:
Code: Select all
gconftool-2 -t boolean -s /desktop/gnome/file_views/show_hidden_files 1
gconftool-2 -t boolean -s /desktop/gnome/file_views/show_backup_files 1


6(cutter). You can also create an alias here. This may not be the best way to do this, but works. To launch Cutter for instance, add
Code: Select all
alias cutter='cd /stuhome/vsfx419/cutter;java -Xmx64m -classpath .:cutter.jar Cutter'
as long as you refer to the correct directory.

I hope that gives you a start

Re: bash_custom

PostPosted: Apr 6th, '10, 13:52
by pmayer20
Upon logging in I am trying to set my theme to Ubuntu Studio. I added this line to my bash custom but receive a permissions error...

gconftool-2 \
--type string \
--set /usr/share/themes/UbuntuStudio UbuntuStudio

Any ideas on how to set the login theme?

Also, gconf-editor in the console will open up a GUI to set the options, but I still receive the same error.

Thanks,
-Phill

Re: bash_custom

PostPosted: Apr 17th, '10, 15:43
by wschil20
there is a folder that stores local theme settings
(when you save from System > Preferences > Appearance)
Code: Select all
/home/$USER/.themes

You'll probably have to have your bash_custom copy that folder from your stuhome to your local home, such as from /stuhome/mytheme to /home/wschil20/.themes/mytheme

I'm still taking a look at this, between gconf and a couple pref files I'm sure it can work...

Re: bash_custom

PostPosted: Apr 23rd, '10, 16:11
by wschil20
well, I haven't done much customization before so I did a LOT of messing around to find this. here you go:

Normally, what you should do is
1. Go to System > Preference > Appearance
2. In the Theme tab, Customize a theme for yourself.
3. "Save As" and name it what you like. (Your settings are stored in /home/$USER/.themes)

However, your profiles get deleted upon logout at SCAD, so, you need to set up the theme each time.
You could try copying a custom theme you to /home/$USER/.themes each time, but it has no way of executing automatically, so here's what you do:
1. Save a custom theme, the same way as before
2. open the description file inside of your new custom theme folder
3. Transcribe the info there into the format below.
4. You can now add something like this to your bash_custom:
Code: Select all
gconftool-2 -t string -s /desktop/gnome/interface/gtk_theme "UbuntuStudio"
gconftool-2 -t string -s /apps/metacity/general/theme "UbuntuStudio"
gconftool-2 -t string -s /desktop/gnome/interface/icon_theme "UbuntuStudio"
gconftool-2 -t string -s /desktop/gnome/interface/gtk_color_scheme \
"fg_color:#cccccccccccc
bg_color:#525252525252
text_color:#000000000000
base_color:#ffffffffffff
selected_fg_color:#ffffffffffff
selected_bg_color:#494942e73b5c
tooltip_fg_color:#b2b2b2b2b2b2
tooltip_bg_color:#323232323232"
gconftool-2 -t integer -s /desktop/gnome/peripherals/mouse/cursor_size 24
gconftool-2 -t string -s  /desktop/gnome/peripherals/mouse/cursor_theme "DMZ-White"

5. Once you set this up, that custom theme you saved is no longer necessary.

I'm not sure what SCAD's policy is on displaying custom backgrounds, which is why I haven't posted it here. If you have the interest, I'm sure you can figure out how to change it. Please note, we do have the capability to lock it.

For you personal reference, the system themes are stored in /usr/share/themes, but they are not writable at SCAD

Re: bash_custom

PostPosted: Jan 9th, '11, 13:34
by rsimon21
About the wallpaper, the IT guys don't care because when someone else logs in the path in, the path to the wallpaper (and theme) is reset to the default because your home folder gets wiped.

Pick a theme from here (I do so love my dark themes :P) http://www.catswhocode.com/blog/20-beau ... and-ubuntu . Be careful though. not all of them work. I find ubuntu studio works best.

Here's my custome theme:

Code: Select all
# theme stuff to be done last.
#Copy over the themes from your own student space into the ~/.themes folder so it has something to pull from
cp -r ~/mount/stuhome/linux/UbuntuStudio ~/.themes

#Launch terminal to get it working. For some reason it has to be set, unset, and refreshed.
gconftool-2 --type string -s /apps/metacity/general/theme "UbuntuStudio"
gconftool-2 --type string -s /desktop/gnome/interface/gtk_theme "UbuntuStudio"
gconftool-2 --type string -s /desktop/gnome/interface/icon_theme "Clearlooks"
gconftool-2 --type string -s /apps/metacity/general/theme "Clearlooks"
gconftool-2 --type string -s /desktop/gnome/interface/gtk_theme "Clearlooks"
gconftool-2 --type string -s /apps/metacity/general/theme "UbuntuStudio"
gconftool-2 --type string -s /desktop/gnome/interface/gtk_theme "UbuntuStudio"
gconftool-2 --type string -s /desktop/gnome/interface/icon_theme "Clearlooks"

# wallpaper yo
gconftool-2 --type string -s /desktop/gnome/background/picture_filename "PATH TO WALLPAPER IMAGE"
#The original path in case I mess something up
#gconftool-2 --type string -s /desktop/gnome/background/picture_filename "/etc/background.bmp"


Bash_custom doesn't get run until you launch terminal so you'll have the default theme until then.

Re: bash_custom

PostPosted: Feb 4th, '11, 09:55
by wschil20
here's a common one that should be the default. Unfortunately this correction didn't make it in to our default profile yet...

Code: Select all
gconftool-2 -t string -s /apps/nautilus/preferences/default_folder_viewer "list_view"