When using the render farm quick check list
● Make sure all the paths in your project are relative!
○ This means you need to set your project and have all the files reference your
project. If you have a texture or other file that is referenced in a folder that is not
contained within your project IT WILL NOT RENDER
○ Store the images you are planning to use in the sourceimages folder
○
○

●

●

●
●

Example of a relative Path: 
cityscene/sourceimages/streetTexture.tif
Example of an absolute Path:
C:/projects/cityscene/sourceimages/streetTexture.tif


If you have a simulation YOU MUST CACHE IT OUT if you want it to work in the farm
○ this is because the farm sends each frame to a different computer and the sim
might be different each time it is run.
Make sure your render times are less than 2 hours perframe
○ If a frame goes above 2 hours on the farm the job will be kicked off the farm
○ If you are getting frames that long you can try making different render layers
and/or passes
Make sure your file names are LESS THAN 25 characters or they will not render
○ This includes project names, layer names, pass names, ect..
Do not use spaces in your names or special characters
○ Write file names in camelcase
■
thisIsHowYouWriteInCamelCase
○ Special Characters include ‘ “ ; : < > \ / ^...ect

Using the farm from scratch (Maya):
1. Open Maya and File → Project Window
a. Click new and name your new project then press accept
b. Set this project by going to File → Set Project and selecting the folder you just
made
2. Save your scene so that it is in the Scenes folder of your project
3. Now make you scene with all your geometry and shaders.
a. If your are bringing in Geometry make sure you save the geometry into your
Assets folder before you bring them in
b. If you are bringing in textures make sure they are saved in your sourcesimages
folder before you bring them into your scene.
c. If you are bringing in a cache make sure it is in you cache folder
4. Once you are ready to render open up your render settings by clicking on the render
button with the gear on it
a. Make sure you select the proper render (mental ray, Renderman, Arnold…)
b. make sure you select the image format you want your files in, iff, tif, exr…
c. change the Frame/Animation ext: to 
name.#.ext
d. Make sure your renderable camera is set to your render camera
e. Finally set the resolution for your images
i.
Just remember that increasing resolution increases render time 4fold

f.

Save and quit

5. Make sure you have activated your account for the render farm
a. Go to the SFDM render farm page h
ttp://render.scad.edu/
and in the top right

hand corner click on “Activate”
b. Log in
c. Read and agree to the terms and conditions and click on C
lick Here
d. You now need to logout and then log back in to be able to upload your project
onto the farm
6. Now it’s time to submit your project to the farm
a. Submitting from Monty
i.
Linux
1. Navigate to /home/{your_login}/mount/renderfarm
2. Copy your entire project you made in Step 1 into this folder
ii.
Windows
1. Navigate to SCAD Shares → Savannah → SDM Render Farm
2. Copy your entire project you made in Step 1 into this folder
b. Submitting from home
i.
Download Filezilla
https://filezillaproject.org/

ii.
Open the FTP and open the Site Manager (the icon beneath file in
filezilla)
iii.
Create a new site and name is SCAD_Render_Farm
iv.
Under host write 
savmyfile.scad.edu
v.
Make sure the Protocol is set to 
SFTP  SSH File Transfer Protocol
vi.
Logon type set to normal and then put your Network username and
password.
7. Let’s submit the job now go back to 
http://render.scad.edu/
a. Click the big blue S
ubmit
button and login with your MyScad Login

b. Now select the renderer that you set up you scene with and click next
c. Now specify a frame range (150, 2530, or only a few select frame 3, 27, 37)
d. Make sure you chose the version of Maya that you made the scene in
e. You can leave the last two drop downs at 0 if you don’t know what they do
f. Press finish and you have now submitted a job to the farm
8. To manage you render you can click on D
ashboard
and it will take you to a list of all your
past jobs.
a. If you want to stop your renders you can click on the k
ill job
on the right under
Action
b. To check on your render click the job number on the left under Job. This will bring
you to the progress of your render
i.
If you want to see the logs for the frame click on the host for that frame
ii.
If your render failed or dropped you can manually go in and click
rerender 
and it will rerender just that frame

9. Once your job completes you can go back to where you put your project file in Step 6
a. Inside the folder called J
ob_{your_job_number}
you can retrieve all your frames
i.
remove your images from the farm or they will be automatically
deleted after 48 hours
Using the farm from scratch (Houdini)
1. Open Houdini and File → New Project
a. Rename the project and save it where you wish
b. Set this project by going to File → Set Project and selecting the folder you just
made
2. Save your .hip file in the top level of your project folder (along side all the folders it
created)
3. Now make you scene with all your geometry and shaders.
a. If your are bringing in Geometry make sure you save the geometry into your g
eo
folder before you bring them in
b. If you are bringing in textures make sure they are saved in your 
tex
folder before
you bring them into your scene.
c. If you are bringing in a cache make sure it is in you s
im
or 
adc
folder
4. Now that your scene is set up let’s make sure you made all your paths relative
a. Go to the Render tab → PreFlight Scene
b. leave $HIP selected and press OK
i.
If everything within $HIP is green you did it correctly.
ii.
If something is red that means you have an absolute path you need to go
change
iii.
If you have a few red .py files at the bottom that is ok and you scene is
still correct, it only matters if it is within the $HIP
5. Once you are ready to render open up your render settings by going to the out page and
selecting your mantra node
a. Make sure you select the proper render (Ray Tracing, PBR, Photon Map…)
b. Make sure your output is something along the lines of:
i.
name
.$F4.ext
1. this give your frames padding to they organise correctly
c. Make sure your camera is set to your render camera
d. Finally set the resolution for your images
i.
Just remember that increasing resolution increases render time 4fold
e. Save and quit

6. Make sure you have activated your account for the render farm
a. Go to the SFDM render farm page h
ttp://render.scad.edu/
and in the top right

hand corner click on “Activate”
b. Log in
c. Read and agree to the terms and conditions and click on C
lick Here

d. You now need to logout and then log back in to be able to upload your project
onto the farm
7. Now it’s time to submit your project to the farm
a. Submitting from Monty
i.
Linux
1. Navigate to /home/{your_login}/mount/renderfarm
2. Copy your entire project you made in Step 1 into this folder
ii.
Windows
1. Navigate to SCAD Shares → Savannah → SDM Render Farm
2. Copy your entire project you made in Step 1 into this folder
b. Submitting from home
i.
Download Filezilla
https://filezillaproject.org/

ii.
Open the FTP and open the Site Manager (the icon beneath file in
filezilla)
iii.
Create a new site and name is SCAD_Render_Farm
iv.
Under host write 
savmyfile.scad.edu
v.
Make sure the Protocol is set to 
SFTP  SSH File Transfer Protocol
vi.
Logon type set to normal and then put your Network username and
password.
8. Let’s submit the job now go back to 
http://render.scad.edu/
a. Click the big blue S
ubmit
button and login with your MyScad Login

b. Now select the renderer that you set up you scene with and click next
c. Now specify a frame range (150, 2530, or only a few select frame 3, 27, 37)
d. Make sure you chose the version of Houdini that you made the scene in
e. You can leave the last two drop downs at 0 if you don’t know what they do
f. Press finish and you have now submitted a job to the farm
9. To manage you render you can click on D
ashboard
and it will take you to a list of all your
past jobs.
a. If you want to stop your renders you can click on the k
ill job
on the right under
Action
b. To check on your render click the job number on the left under Job. This will bring
you to the progress of your render
i.
If you want to see the logs for the frame click on the host for that frame
ii.
If your render failed or dropped you can manually go in and click
rerender 
and it will rerender just that frame
10. Once your job completes you can go back to where you put your project file in Step 6
a. Inside the folder called J
ob_{your_job_number}
you can retrieve all your frames
i.
remove your images from the farm or they will be automatically
deleted after 48 hours

To begin using the farm you must first activate your account.

Go to the SFDM render farm page h
ttp://render.scad.edu/
and in the top right hand

corner click on “Activate”
All my projects and frames are gone from the render farm
I am sorry but the way the new farm is set up is it pulls renders directly from your folder
to send to the other machines. This is so that it speeds up the time it takes for a job to be
transferred to the farm to render. Because of this after a few days all the projects and
related frames are removed from the farm to save space. So after your project finishes
render remove you frames and also just know that any job you put on the farm should be
a copy and not storage.
My Job is small and doesn’t take long but it has been on the farm for hours
The new farm is purely firstcomefirstserve. If there are other larger projects ahead of
yours you will have to wait for those to finish. There is a 250 frame cap as well as a 2
hour cap so people's projects cannot get too big, but sometimes especially during finals
you will need to wait in line no matter what the render time on your project is. 
Breaking
up your project into to smaller renders segments (like 50 frames at a time) Will not
increase how quickly you are able to render.

There are over 100 empty nodes on the farm but my Arnold project is only using a few of
them
We only currently have 80 licenses to Arnold. 50 of these licenses are the most the farm
will use. this allows people to be working locally on Arnold as well as rendering with it on
the farm without getting a watermark. Because only 50 licenses can ever be active on
the farm there can only be 50 Arnold frames rendering at a single time.
How do I connect to the FTP (Filezilla or Fetch or other)
Step 1: Open the FTP and open the Site Manager (the icon beneath file in filezilla)
Step 2: Create a new site and name is SCAD_Render_Farm
Step 3: Under host write 
savmyfile.scad.edu
Step 4: Make sure the Protocol is set to 
SFTP  SSH File Transfer Protocol
Step 5: Logon type set to normal and then put your Network username and password.
Step 5: You can now connect to the farm and you are able to transfer your files from
anywhere
All my frames came out as 
name
.ext.number (finalFinalLighthouse.exr.0012)
Don’t worry and don’t rerender all your frames. Follow this link and you can run a script
that will change your files very quickly
https://docs.google.com/document/d/1SWjzMTs4edGUFRtgO9uIRlj5GJhYalJmTHM_9R49edk/edit?usp=sha
ring

Renderman dropping objects when rendering. The current solution is two steps,
sometimes you only need to run the first step and sometimes both are required.
Step 1: Go to Render settings > RenderMan/Ris > Advanced tab > RIB Options >
Check Flatten
If that doesn't fix the problem you will need to generate .rib files
Step 2: Open up the script editor and write:
rman genrib
and run this command. Sometimes this takes a few minutes and will generate your
scenes .rib files. This should now solve your problem
My frames are dropping but I am getting no errors
It is because the computer render farm is trying to use has been logged on by students.
The render farm uses any idle machine in Monty, but if a student touches the machine
and intend to use it, it will break from the farm and cause the render to fail.
Sometimes during the busy school hours, this could happen multiple time, in this case,
the farm will drop this frame completely. You would need to resubmit a job for these
dropped frames
I put my Houdini file on the farm but i cannot select it to render
Houdini files need to be place inside of a project for the farm to find it. Either make a
project and place the .hip inside of it or make a folder and dump everything in the folder,
but make sure your paths are still relative.
What renders are on the renderfarm
Renderman for Maya
Arnold for Maya 2016
Mental Ray
Mantra
Maya software
Why can’t my job which doesn’t take long at all jump ahead of a project that is taking
forever to finish
The way the farm is set up is on a first come first serve. This means you have to wait on
the people before you for you to get your render started. This is the most democratic way for us
to set up the farm without someone dedicated to wrangling the farm 24/7. There are no plans to
bring priority back.

